Wednesday, August 22, 2007

Another Bust For Garmin

I tried to turn on my Garmin on Monday and it worked and I thought all was well. But this morning I tried it again and it just sat there not responding. So I guess I will have to do the inevitable and write to Garmin to see what they will do towards a repair or replacement.

We did 5.0 miles at a 13.11 minute/mile pace for a total time of 1:05:55. It was warm muggy humid morning. I will try to write more later if I have time.

Have a Great Hump Day!!!

6 comments:

Marcy said...

That stinks Randy! How long have you had it? Hopefully they'll hook you up with some sort of fix or replacement ;D

Great job on the run!

Jess said...

How long have you had it? Is it old?

Michelle said...

Oh no, Randy!!

From what I hear, Garmin has an excellent track record of either fixing or replacing Garmins that are on the fritz. I hope you're able to get yours taken care of! I am so lucky that mine hasn't given me any problems yet!

Lisa - Slow & Steady said...

best wishes with the Garmin repair.

I can't tell you how many times my long runs have come in at about 13.1 MPH. If only you folks lived closer, I'd have a group to run with!

Molly said...

Sorry 'bout that! Hope the Garmin starts behaving soon!

Take Care!

teacherwoman said...

I have had a couple problems with mine this summer as well. It would lock up when I would turn it on, but it would work after I took the batteries out and put them back in.

NICE job on the 5 miles! Happy hump day!